I've used elementary OS before, but I wasn't really interested in creating an account here.

I was browsing the new questions out of curiosity, and tried to edit typos out of the title of a question, but found that I was not able to do so without creating an account. This is not generally necessary on any site in the network, whether one is logged into a Stack Exchange account or not, there is always the "improve this question" button below the post.

On the posts on this site, when you are not logged in to an elementary OS SE account (whether you have one or not), there is no "improve this question" button underneath a post. (I'd post pictures, but Imgur is giving me trouble today). This can be tested in incognito mode.

If it makes a difference, I viewed the question originally in Chrome 56 on Windows 10. (no updates available for either)

  • As an aside, I was mostly wondering why Elementary needs its own site; surely it's on-topic on U&L. Is there a meta post here on that?
    – Shokhet
    Commented Feb 22, 2017 at 17:18
  • 1
    Technically on topic, until this site was made. Ubuntu has it's own site too.
    – Lewis Goddard Mod
    Commented Feb 22, 2017 at 20:37
  • @LewisGoddard Okay, I see.
    – Shokhet
    Commented Feb 22, 2017 at 20:38

1 Answer 1


The post was less than 10 minutes old when you tried to edit; anonymous editing is only enabled after the question has been live for a bit, to prevent blocking the author and other editors who often make quick edits soon after the post is created.

  • I actually cannot edit/improve this very answer from 2017 unless I'm logged in. So I don't think that was the issue..
    – jena
    Commented Oct 3, 2019 at 13:34
  • No suggested edits on meta sites, @jena. We may have to revisit that.
    – Shog9
    Commented Oct 3, 2019 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .